cupsmission.com website / SSL / email DNS incident — June 23–24, 2026
Resolved
Jun 24, 2026 at 5:11pm UTC
The issue was resolved.
Affected services
Created
Jun 24, 2026 at 12:16pm UTC
On the evening of June 23, 2026, a user first reported a problem accessing cupsmission.com. The next morning, additional reports confirmed that the website was either unavailable or presenting SSL/security warnings. During initial triage, DNS/nameserver behavior appeared inconsistent: the registrar reportedly showed the expected nameservers, while external lookup behavior referenced another vendor’s nameservers.
By approximately 8:50 AM on June 24, inbound emails for the domain were confirmed not working. The issue affected multiple tested email addresses, and was treated as organization-wide for 50+ users. DNS records for related email authentication services were reviewed and re-added or confirmed during triage.
Some senders’ messages may have bounced during the incident. Some users may have seen different website behavior depending on resolver/cache/propagation state. Donation pages, forms, and other website functions were also affected.
Vendor support interactions indicated that the issue was likely DNS-related rather than our email provider serving an account restriction. One vendor identified a discrepancy between WHOIS/registry-level nameserver data and DNS zone behavior. Another vendor later confirmed that the domain’s DNS had been corrected under another support ticket and that MX/SPF records were correct.
Email began working again around 1:11 PM EDT on June 24. The confirmed outage window is approximately 4 hours 21 minutes from first confirmation to observed recovery. The true window may have started earlier. The root cause has not been conclusively determined. The best-supported finding is that cupsmission.com experienced a DNS authority or zone inconsistency involving the intended nameservers and another vendor's DNS infrastructure. During the incident, registrar/WHOIS information reportedly showed the intended private nameservers, while external lookup behavior and vendor comments indicated their nameservers or their controlled DNS data were involved. This appears to have caused inconsistent website resolution, SSL certificate warnings, and inbound mail failures until DNS records were corrected and propagated.
Affected services